Email Notification/2FA delays (Mandrill/Mailchimp)
Incident Report for Snapdocs, Inc.
Resolved
This incident has been resolved.
Posted Mar 06, 2023 - 11:29 PST
Monitoring
Our third party email provider has resolved the issue causing email notifications and 2FA codes to be delayed. We will continue to monitor the situation.
Posted Mar 06, 2023 - 10:36 PST
Identified
We are currently experiencing a delay in email notifications and 2FA codes sent by our third party email provider. Please refrain from requesting a new code if you have not yet received your two-factor authentication code via email. Doing so may cause additional delays.
Posted Mar 06, 2023 - 09:59 PST
This incident affected: Outbound Emails (East Coast Servers, West Coast Servers).