Snapdocs Support Emails
Incident Report for Snapdocs, Inc.
Resolved
This incident has been resolved.
Posted Sep 12, 2024 - 16:01 PDT
Monitoring
A fix has been implemented, sending and receiving emails functionality has returned. Please email support@snapdocs.com or call 1-833-762-7362 with any further questions
Posted Sep 12, 2024 - 13:24 PDT
Identified
The Snapdocs Support team is experiencing intermittent issues with sending and receiving emails due to an email management tool impact. They have identified the issue and are working on a resolution. If there is an urgent request or action needed we recommend calling in to 1-833-762-7362. We will continue to keep you updated.
Posted Sep 12, 2024 - 12:27 PDT
This incident affected: Support Emails.