Encompass - Loan Processing Issues

Incident Report for Snapdocs, Inc.

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 11:54 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 30, 2026 - 08:34 PDT

Update

Snapdocs customers integrated with Encompass may continue to experience delays as Encompass works to resolve an ongoing service disruption. As a workaround, we recommend manually creating closings within Snapdocs for any urgent transactions. Please contact support@snapdocs.com for any questions.
Posted Jul 30, 2026 - 07:47 PDT

Investigating

Snapdocs is experiencing some intermittent issues retrieving documents and closing creation from ICE.
Posted Jul 30, 2026 - 07:36 PDT
This incident affected: Closings.