Some users are reporting issues with eSigning
Incident Report for Snapdocs, Inc.
Resolved
This incident has been resolved.
Posted Sep 01, 2023 - 11:56 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 01, 2023 - 10:41 PDT
Update
A small number of users are reporting issues with eSigning when performed on a mobile device. We are continuing to work on a fix for this issue.

Effective workarounds for impacted users include
1) Using a laptop or desktop computer to eSign
2) Using a browser other than Chrome on your mobile device. Firefox has worked for other users to eSign.

If a user continues to experience issues please contact our support team at support@snapdocs.com.
Posted Sep 01, 2023 - 06:52 PDT
Update
We are continuing to work on a fix for this issue.

Effective workarounds for impacted users include
1) Using a laptop or desktop computer to eSign
2) Using a browser other than Chrome on your mobile device. Firefox has worked for other users to eSign.
Posted Sep 01, 2023 - 05:44 PDT
Update
A small number of users are reporting issues with eSigning when performed on an Android mobile device using the latest release of the Chrome browser. We have identified the issue and are actively working on a fix.

If a user encounters this issue, we recommend one of the following workarounds which have been proven effective:
1) Use a laptop or desktop computer, and any browser, to eSign.
2) Use a browser other than Chrome on your Android mobile device (Firefox has worked for other users).

If a user continues to experience issues please contact our support team at support@snapdocs.com.
Posted Aug 31, 2023 - 17:56 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 31, 2023 - 14:45 PDT
Identified
The issue has been identified and a fix is being implemented. Please be advised that eSigning on a desktop or laptop continues to be an effective workaround for impacted users.
Posted Aug 31, 2023 - 11:57 PDT
Update
We are continuing to investigate this issue. eSigning on a desktop or laptop may be an effective workaround for impacted users.
Posted Aug 31, 2023 - 11:05 PDT
Investigating
A small number of users are experiencing issues with attempts to eSign. Our engineers are investigating.
Posted Aug 31, 2023 - 09:53 PDT
This incident affected: Closings.