Email Provider Issues

Incident Report for Snapdocs, Inc.

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 09:22 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 23, 2025 - 17:10 PDT

Update

Issues around logging into Snapdocs should now be resolved. Work continues for full resolution of this issue
Posted Apr 23, 2025 - 16:14 PDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 23, 2025 - 15:44 PDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 23, 2025 - 15:13 PDT

Identified

Snapdocs is currently experiencing an email disruption due to an outage with one of our email providers. We understand the importance of email communication and are actively working to resolve this issue. Our team is in the process of re-routing all email traffic to an alternate provider to ensure continuity of service. We apologize for any inconvenience this may cause and will provide updates as they become available.
Posted Apr 23, 2025 - 14:57 PDT
This incident affected: Notary Connect and Closings.