Digital Closings - Document Processing Delays

Incident Report for Snapdocs, Inc.

Resolved

This incident has been resolved. Please contact support@snapdocs.com with any further questions.
Posted Mar 19, 2025 - 13:40 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2025 - 10:29 PDT

Update

Work continues to resolve the identified issue with Encompass Loan Connect. Our status page will remain active until a resolution is implemented. Please contact support@snapdocs.com with any further questions.
Posted Mar 17, 2025 - 18:16 PDT

Update

We are continuing to work on a fix for this issue affecting customers that have updated their Encompass Loan Connect experience.
Posted Mar 17, 2025 - 13:11 PDT

Update

We continue to investigate delays in uploading documents for customers that have updated their Encompass Loan Connect experience. We will provide updates every 2 hours moving forward.
Posted Mar 17, 2025 - 10:49 PDT

Identified

We are experiencing delays uploading documents for customers that have updated their Encompass Loan Connect experience
Posted Mar 17, 2025 - 09:46 PDT

Update

We are continuing to investigate this issue.
Posted Mar 17, 2025 - 09:01 PDT

Update

We are continuing to investigate this issue.
Posted Mar 17, 2025 - 08:11 PDT

Investigating

We are currently experiencing a delay in document processing. We are currently investigating and will have another update in 45 minutes
Posted Mar 17, 2025 - 07:22 PDT
This incident affected: Closings.