Unable to access closing documents
Incident Report for Snapdocs, Inc.
Resolved
This incident has been resolved.
Posted Feb 29, 2024 - 16:33 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 29, 2024 - 16:04 PST
Investigating
Users on the Closings platform are experiencing issues accessing closings and documents. We are currently investigating.
Posted Feb 29, 2024 - 15:55 PST
This incident affected: Closings.