3rd party Snapdocs Email provider, Sendgrid, is experiencing issues with email delivery

Incident Report for Snapdocs, Inc.

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 09:16 PST

Update

Snapdocs engineering has identified that the issue is related to the Microsoft outage for 365 Services including email delivery.
Microsoft's Status page- https://status.cloud.microsoft/
Posted Jan 22, 2026 - 13:32 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 22, 2026 - 12:29 PST

Update

We are continuing to investigate this issue.
Posted Jan 22, 2026 - 12:22 PST

Investigating

Snapdocs is currently experiencing email delivery issues with one of our email providers. We understand the importance of email communication and are actively working to resolve this issue. Our team is in the process of re-routing all email traffic to an alternate provider to ensure continuity of service. We apologize for any inconvenience this may cause and will provide updates as they become available.
Posted Jan 22, 2026 - 12:21 PST
This incident affected: Notary Connect and Closings.