SMS + MFA Delivery Issues

Incident Report for Snapdocs, Inc.

Resolved

This incident has been upgraded to a larger incident
Posted Oct 20, 2025 - 10:53 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 06:58 PDT

Update

We continue to investigate this issue. For the quickest resolution, please email support@snapdocs.com.
Posted Oct 20, 2025 - 05:37 PDT

Identified

We are currently experiencing an outage affecting 2FA code delivery from our third-party provider. Our team is investigating and will share another update within 30 minutes.
Posted Oct 20, 2025 - 04:46 PDT
This incident affected: Notary Connect, Closings and Text Messages (Twilio SMS).