Email Vendor Issues

Incident Report for Snapdocs, Inc.

Resolved

This incident has been resolved.
Posted Apr 25, 2025 - 09:01 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 25, 2025 - 07:29 PDT

Investigating

Snapdocs Support is currently experiencing technical difficulties with our email vendor. This may result in delayed responses or other disruptions to email-based support services.

For the fastest possible assistance, please contact our Support team directly by phone at 833-762-7362.
Posted Apr 25, 2025 - 07:01 PDT
This incident affected: Notary Connect, Closings, and Support Emails.