Funding Review QC Reports and eFoldering delayed

Incident Report for Snapdocs, Inc.

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 14:42 PDT

Monitoring

Funding QC Reviews are no longer experiencing delays, we are continuing to monitor for the next 30 minutes
Posted Jun 12, 2025 - 14:01 PDT

Identified

Due to an issue with Google Cloud, some transactions are experiencing delays with Funding QC Reviews and eFoldering
Posted Jun 12, 2025 - 13:29 PDT
This incident affected: Closings.