Microsoft Outlook Outage
Incident Report for Snapdocs, Inc.
Resolved
This incident has been resolved.
Posted Nov 25, 2024 - 14:29 PST
Monitoring
Please be aware that Microsoft Outlook is currently experiencing an outage, which may cause delays in email communication. For faster responses, please message directly on the Snapdocs platform or contact Snapdocs Support by phone.
Posted Nov 25, 2024 - 09:04 PST
This incident affected: Notary Connect, Closings, and Support Emails.