Snapdocs Internal Platform degraded performance
Incident Report for Snapdocs, Inc.
Resolved
This incident has been resolved.
Posted Mar 13, 2023 - 10:35 PDT
Monitoring
Snapdocs has returned to normal operations. We will continue to monitor for 1 hour.
Posted Mar 13, 2023 - 09:29 PDT
Investigating
Actively investigating degraded performance on Snapdocs platform. Doc processing times may be delayed as a result.
Posted Mar 13, 2023 - 09:05 PDT
This incident affected: Closings.