AWS Incident
Incident Report for Snapdocs, Inc.
Resolved
This incident has been resolved.
Posted Sep 19, 2023 - 05:09 PDT
Monitoring
AWS has implemented a fix for this issue. Snapdocs will continue to monitor until fully resolved.
Posted Sep 18, 2023 - 15:58 PDT
Update
We are continuing to work with AWS to resolve this issue.
Posted Sep 18, 2023 - 13:26 PDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 18, 2023 - 12:17 PDT
Identified
An AWS outage is impacting our system. We are seeing some degraded performance.
Posted Sep 18, 2023 - 12:14 PDT
This incident affected: Mobile Notary, Closings, and eVault.