Snapdocs Support - Phone Outage

Incident Report for Snapdocs, Inc.

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 15:21 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2025 - 14:13 PDT

Update

Phone services remain unavailable due to the ongoing outage. Support is still actively monitoring and responding to emails. For any support inquiries, please reach us at support@snapdocs.com.
Posted Jun 12, 2025 - 13:17 PDT

Identified

We are experiencing a temporary phone outage with our provider. Consequently, our support team is currently unable to answer phone calls. However, we are actively monitoring and responding to emails. For any support inquiries, please reach us at support@snapdocs.com. We will provide updates as soon as our phone service is restored.
Posted Jun 12, 2025 - 11:30 PDT
This incident affected: Notary Connect, Closings and Text Messages (Twilio SMS).