Document Upload issues for Full Redraw submissions via EPC

Incident Report for Snapdocs, Inc.

Resolved

This incident has been resolved.
Posted Jun 17, 2025 - 16:30 PDT

Monitoring

A fix has been implemented and we are monitoring for the next 30 minutes.
Posted Jun 17, 2025 - 15:58 PDT

Identified

We have identified an issue with Full Redraw submissions sent via EPC. Document upload is not working as expected.

As a workaround, please submit all closings as a new closing to ensure documents are uploaded successfully.
Posted Jun 17, 2025 - 12:22 PDT
This incident affected: Closings.