Snapdocs Support Email Outage
Incident Report for Snapdocs, Inc.
Resolved
This incident has been resolved.
Posted Jul 27, 2023 - 18:11 PDT
Monitoring
A fix has been implemented and we are monitoring results. Please reach out via phone to our support team for any questions.
Posted Jul 27, 2023 - 15:34 PDT
Update
Our email provider is still working to resolve the issue. We are still able to take phone calls. Please do not hesitate to reach out by phone. We hope to have emails up and running again soon. Thank you for your patience.
Posted Jul 27, 2023 - 14:09 PDT
Identified
Our email provider has reported an outage. Due to this, our support team is unable to receive or respond to emails. We are still able to receive phone calls. They have identified the issue and are working on a resolution. We will continue to keep you updated.
Posted Jul 27, 2023 - 09:48 PDT
This incident affected: Outbound Emails (East Coast Servers, West Coast Servers) and Support Emails.