Snapdocs VPN Issues
Incident Report for Snapdocs, Inc.
Resolved
This issue is now fully resolved as processing times for closings are back to normal.

Please reach out to our support team with any questions or concerns. Thank you.
Posted Sep 26, 2022 - 09:13 PDT
Monitoring
Our internal team is now able to access their VPN. Please continue to expect longer processing times for all closings, and reach out to support@snapdocs.com if you have any questions or concerns.
Posted Sep 26, 2022 - 08:23 PDT
Investigating
Our internal team is experiencing issues connecting to our VPN. This will result in longer than usual processing times for all closings. We are investigating the issue and will provide updates when available.
Posted Sep 26, 2022 - 06:45 PDT
This incident affected: Closings.