Intermittent Slowness on Site
Incident Report for Snapdocs, Inc.
Resolved
Site slowness has been resolved.

Users should no longer experience any issues when navigating the Snapdocs platform. If there are any questions, we are happy to help, please send us a message at support@snapdocs.com
Posted Nov 09, 2019 - 09:13 PST
Monitoring
Engineering has successfully fixed the slowness on our site. We will continue to monitor the situation to make sure this is completely resolved. Thank you for your patience.
Posted Nov 09, 2019 - 09:06 PST
Investigating
We are currently experiencing intermittent slowness on our website upon login. Our engineers are aware of the issue and currently working on a fix. We will provide additional updates soon.
Posted Nov 09, 2019 - 08:43 PST
This incident affected: Mobile Notary and Closings.